Main Region

How do I get the grid combo box (or the popup LOV) to translate the ID into the text value?
8 answers | 860 views

JO
Jul 29, 2013 17:14 +00:00

I have a window with a foex-form an several field containers which I just show when the user selects single mode editing.

If I select a row (via context menu) from the grid, the Window opens and shows the fields which are selected. This is done via DA and works fine for text fields and select lists. It does not work for the grid combo box (neither the popup LOV). I dont' get it to show the proper text value, whereas the ID-value is set and it ist right.

I tried several actions like FOEX Form Reset and FOEX Form Load before I show the window.

Maybe this doesn't work with simply toggling between show and hide of the single edit window.

It drives me crazy !!!

5 comments

MN
Matt Nolan Jul 30, 2013 05:01 +00:00 

Do you have an environment that you can provide me access to instead of creating a test case on demo.tryfoexnow.com.

Also the test case just needs to reproduce the problem, so usually you can get away with creating an extra page in the documentation app based on the demo tables. To get a workspace you just click the "try it now" button on our website.

JO
Jochen Jul 30, 2013 07:15 +00:00 

Supplement

when I "used" the grid combo box it seems that all subsequent calls work fine and the grid combo box is populated properly. Some kind of a "wake up" problem

JO
Jochen Jul 30, 2013 11:16 +00:00 

Second finding when I use a FOEX Text Field instead of an APEX Text Field the values are not set on first call either. So - as a resume - setting genuine APEX fields works fine, setting FOEX field types doesn't work, or works only on second call or works only on wake up.

This might be true only for setups where the Session variables are set via AJAX calls or Dynamic Actions respectively

MN
Matt Nolan Dec 3, 2014 15:40 +00:00 

What version are you using?

MN
Matt Nolan Dec 3, 2014 16:03 +00:00 

Please create a simple test on demo.tryfoexnow.com that shows your setup so we can investigate and see what you are doing.

MN
Jul 29, 2013 17:28 +00:00

In order for me to help you are you able to create a test case on demo.tryfoexnow.com?

I know it's frustrating having to create test cases but it the quickest way which I can help you and understand what you are doing.

0 comments

JO
Jul 29, 2013 18:53 +00:00

Oh man, never did that before. Don't i have to provide all the ground work, table, view type structures etc.? Fact is, that things have gotten complicated insofar that i am switching from a apex/manually integrated extjs environment to foex. So the data layer is basically provided through object types and views.

But the thing here isq, that all the logic on the site is handled by DA know and i think i am struggeling in handling the data through session variables, page variables and the extjs items. It seems that i have to get the key to triggering the grid combo box after the varables have been set.

0 comments

JO
Jul 30, 2013 07:06 +00:00

Hi Matt,

thanks for the offer. Before I set up a test case I ran some tests. Maybe it's enough info for you when I describe what I found out so far.

  1. General setup.
  2. I have a classic report based editable grid on Page 2 which shows all companies
  3. Additionally I have a Window - From - Field Container with the company fields for single edit mode (name, short name, parent id, sector id etc.)
  4. Bringing up the single edit mode window is achieved through context menu
  5. therefore I use a hidden page item :P2_ID_COMPANY_CONTEXT taking the id of the chosen company
  6. all fields are set to "only when current value in session state is null" and "Static Assignment" in the source section

  7. Functioning

  8. when the user activates the context menu (edit) a DA is called listening to the "EDIT" event (works fine)
  9. what I do here is (a) check if the context menu action is "edit" (works fine) (b) load the object type OT_COMPANY with the value of :P2_ID_COMPANY_CONTEXT (works fine) I submit all page items and I return them all (options: "Page Items to Submit" and "Page Items to Return") (c) I bring up the window with the "Show"-Action (works fine)

  10. Behaviour (a) on first call: Text fields an grid combo box (getting the parent ID) are not populated select lists an the popup LOV (parent id 2 - just for testing purposes) are filled properly

(b) on second call: Text fields an select lists are filled properly The grid combo box AND the popup LOV are showing the PARENT-ID respectively (not the text values)

  1. TEST When setting the page item P2_ID_PARENT (which is the grid combo box) in a PL/SQL-Procedure on page load) to some value, this value populates the grid combo box on first call. BUT it ist overridden on second call with the parent ID of the chosen company again.

  2. Conclusion It must have to to with my handling of session variables in combination with the Dynamic Action setup.

what is really strange is, that the list boxes and the popup LOV are populated properly on the first call. that the popup LOV is acting the same way like the grid combo box on second call in showing the numeric ID and not the text, so if they need a nudge or something

Matt! If this information doesn't help you I figure out some test case or something else, but this will take some time cause I am busy with some other work this week

thanks again for your help and your commitment - Jochen

P.S: I do have an environment on my laptop (Oracle XE 11g, APEX 4.2.1), but unless it's a company laptop how could I provide remote access for you?

0 comments

MN
Jul 30, 2013 13:10 +00:00

I'm afraid that wth all the details I'm going to need a test case to see exactly what you've done so I can determine if you have an incorrect setup or what we need to fix. This also applies for your text field issue which

One thing that I might be able to point out is that is you use the standard APEX "Set Values" dynamic action for a grid combo or popup lov and the data is not present within their lists then you will see the ID value since no display value can be located in their store. However the Form Load dynamic action will set these correctly since it will bring the display valkue back in the AJAX call. I have logged an enhancement request to create a new FOEX Set Values dynamic action which should make it into the forthcoming v1.1.3 release.

0 comments

AW
Dec 3, 2014 15:38 +00:00

Hi Jochen

Did you ever get a resolution to this? I have a similar issue.

Thanks

0 comments

AW
Dec 3, 2014 16:00 +00:00

we're using version 1.2.4 still

0 comments

MN
Dec 4, 2014 08:54 +00:00

Yes the FDA is backwards compatible. If the chrome webstore is blocked then the chrome extension is also available in your FOEX software download. Just go to ./addon/fda_chrome.crx and drag this into your extensions page.

0 comments

AW
Dec 4, 2014 09:17 +00:00

The v2 download link we were sent is broken. I understand that the license fees have been paid, so could we have a new link please. If this is not the case please let me know ASAP.

0 comments

You must log in or sign up to post questions and answers.